Accessing Mindget Connect through a Proxy

  • 6
  • Problem
  • Updated 6 years ago
  • Solved
I can't configure Proxy options en MindManager 2012. When I try to use Mindjet connect through a Proxy, I can't, and I remain offline. Is it possible or it's a problem related with my company? Thanks.
Photo of Fernando Vegas

Fernando Vegas

  • 5 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 6
Photo of Andreas Lercher

Andreas Lercher

  • 17 Posts
  • 1 Reply Like
in the MindManager installation directory you finde the file MindManager.config.
Edit with the text editor and delete the text between and
see pic.

should be corrected with service pack 1.

regards
Andreas
www.lerchertrain.at
Photo of Ronnie

Ronnie

  • 2 Posts
  • 0 Reply Likes
Hi,

I have the same problem. I made the changes by replacing "False" with "True" but still not working.

Any idea?

Thanks
Ronnie
Photo of Brittney Mazzetta

Brittney Mazzetta

  • 1981 Posts
  • 68 Reply Likes
Ronnie, if you are still experiencing problems with this, please contact our support team as they will be able to best assist you with this. https://secure.mindjet.com/support/co....
Photo of Fernando Vegas

Fernando Vegas

  • 5 Posts
  • 0 Reply Likes
MindManager does not have proxy settings of it's own but reads the settings from the internet options of Internet Explorer.

In case MindManager still cannot connect, open the Mindmanager.config file which you can find in the MindManager application folder and remove the lines beginning with "system.net" and ending with "/system.net"

MindManager must be closed during these steps.

(Steven Fox, from MindJet, gave me this solution, and it works)
Photo of Ronnie

Ronnie

  • 2 Posts
  • 0 Reply Likes
Hi

Do you meant system.net?

Thanks
Photo of Matts-Ola

Matts-Ola

  • 1 Post
  • 0 Reply Likes
Hi
I removed defaultProxy so that I got

(system.net)
(connectionManagement)
(add address="*" maxconnection="12" /)
(/connectionManagement)
(/system.net)

Now it works. Using () here since text between <> becomes invisible when posting in this forum. Probably why it is empty after "with and ending with " in Fernando's posting above.
Photo of Brittney Mazzetta

Brittney Mazzetta

  • 1981 Posts
  • 68 Reply Likes
Glad to hear this is working for you!
Photo of CaaroLex

CaaroLex

  • 1 Post
  • 0 Reply Likes
To connect to Mindjet Conntect I changed the config file as discribed above but it doesn't work. When starting Mindmanager, Connect tries to connect and after a few seconds offline appears again.

Does anybody has an idea? Are there any special proxy settings which I can give to ours admins?
Thanks for help
Alex
Photo of Brittney Mazzetta

Brittney Mazzetta

  • 1981 Posts
  • 68 Reply Likes
Hello Alex.

Please feel free to open a ticket with our support team: https://secure.mindjet.com/support/co.... They will be able to assist you with this. Thank you.
Photo of ph4wks

ph4wks

  • 2 Posts
  • 0 Reply Likes
Our company uses proxy.pac files in IE to process requests.

Can Mindmanager Connect cope with PAC file proxy types?
Photo of Brittney Mazzetta

Brittney Mazzetta

  • 1981 Posts
  • 68 Reply Likes
You can specify a location for a pac file, following is an example. We recommend you make a backup of your “mindmanager.config” file before making any changes. Revert back to the original file and contact support if you still cannot get Mindmanager to work with proxy. Due to every proxy being configured slightly different, we would be happy to assist if needed.

The mindmanger.config is located in
“C:\Program Files (x86)\Mindjet\MindManager 10\”

Change the system.net stanza to the following:
(that is everything between the opening system.net to closing /system.net)
Make sure to change your proxyaddress and scriptLocation for your environment.



<system.net>
<defaultProxy useDefaultCredentials="true">
<proxy
usesystemdefault="true"
proxyaddress="http://myproxy.com:8080"
bypassonlocal="true"
scriptLocation="http://server/default.pac"
/>
</defaultProxy>
<connectionManagement>
<add address="*" maxconnection="12" />
</connectionManagement>
</system.net>
Photo of ph4wks

ph4wks

  • 2 Posts
  • 0 Reply Likes
Hello,

Many thanks for your reply. This will work I have no doubt.

However is there no way MM can dynamically take the PAC file location from the IE Autoproxy field? (AutoConfigURL in the Internet Settings Reg entry)

Hard coding it into the config for 100's of people isn't strategic enough a solution in case the PAC URL changes.
Photo of Brittney Mazzetta

Brittney Mazzetta

  • 1981 Posts
  • 68 Reply Likes
If you remove the "system.net" section, MindManager will then follow what is configured in IE. I hope that helps!
Photo of andersernblad

andersernblad

  • 1 Post
  • 0 Reply Likes
We run with a .PAC-file and the above solution worked fine for me.
Photo of Onkel Horst

Onkel Horst

  • 1 Post
  • 0 Reply Likes
I have the same problem to connect via a proxy configured using a .pac file... tried several of the above solutions but none was working... is there a way to configure the ip/port of the proxy or the .pac-file in the mindmanager configuration file?
Photo of Brittney Mazzetta

Brittney Mazzetta

  • 1981 Posts
  • 68 Reply Likes
In order to best assist you, I would recommend opening a ticket with our support team. They will need to gather additional information regarding the issue that you are currently experiencing. Please use this link: https://secure.mindjet.com/support/co... to open a ticket with our team. Thank you!

This conversation is no longer open for comments or replies.