Add Link to Local File produces wrong path or double path with quotations

  • 1
  • Problem
  • Updated 2 years ago
Using Mindjet MindManager 17.
On Macbook pro running windows 10 virtual machine.
Files are all saved on the root not a shared folder. (Shared folders on VM cause all sorts of problems but those are for another thread)

I have several Mindjet files all exported to HTML5.

I am trying to create a link in one of the files to link to another html mindjet output file.


Mind jet seems to want to add an extra set of quotation marks around the file path link and this is breaking the link.

Here is what I am getting:

file:///C:/MindMap/02.%20Standard%20U...%22

or incase you are not familiar with what %22 means...

file:///C:/MindMap/02.%20Standard%20U..."

What this should be is:
file:///C:/MindMap/02.%20Standard%20U...

For whatever reason MindJet is adding an extra quotation marks at the end of the url.

If I view the html source here is what the code shows and also what i suspect is the problem:

<a id="v-165" class="mmap-hyperlink" xmlns:xlink="http://www.w3.org/1999/xlink"; xlink:href="&quot;..\..\..\..\..\MindMap\01. Standard User.html&quot;" target="_blank">

No idea why there are so many ..\ but this seems to be the case no matter how the link is set up.  This does go to the right place with the exception of the extra quotation at the end.

Notice this html has "&quot; 
this is two " in a row.

Anyways, if I could get some help here that would be awesome. This problem is pretty much eliminating MindJet as an option for my project.
Photo of Matthew Steele

Matthew Steele

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of jerry.mings

jerry.mings

  • 132 Posts
  • 21 Reply Likes
One thing to consider is how to name files and links to files.  As a general rule, I like to make sure my files have only one period and no spaces.

Example
Problem file name -  01. test file.html

Better file name 01_test_file.html

The key is to allow the machine to read all the way to the period and not experience any spaces.

Hope that helps.

Jerry
Photo of Matthew Steele

Matthew Steele

  • 2 Posts
  • 0 Reply Likes
Great suggestion and that did indeed fix the problem to a point.

The linking process is still broken in MindJet.  The only way i could actually get it to work was to put a bad link in. Go back to the link so that the broken link dialogue box pops up then modify the location. This seems to stop mindjet from making up its own path and actually using the path i tell it to use.

Doing this combined with your suggestion of no spaces and periods the issue can be worked around.
(Edited)