Bug when moving decisions

  • 1
  • Problem
  • Updated 4 days ago
  • Acknowledged


When moving decisions in our template for BPMN the following problem occurs:



As you can see, when moving the exclusive gateway on the right-hand side, MM deletes both decision icons above automatically, eventhough the icons are not connected.
I think that there is a bug. 
It would be very nice if anyone could help me.    


Martin Lange
Photo of Martin Lange

Martin Lange

  • 3 Posts
  • 0 Reply Likes

Posted 4 weeks ago

  • 1
Photo of Ary Velstra, Expert Trainer

Ary Velstra, Expert Trainer

  • 1819 Posts
  • 306 Reply Likes
It looks you are right about the bug.
Although it may have already been solved in MM2020.

However... It appears to me that the column at the right is a Legend created on a background object, so just to inform the reader what the icons mean. If I am correct, the arrow with the second exclusive should not be there at all.
One way to be sure that no-one can mess up your legend, is by Grouping and Locking the background objects where needed.
(Edited)
Photo of Martin Lange

Martin Lange

  • 3 Posts
  • 0 Reply Likes
Hello Mr. Velstra, Thank you very much for your reply.
Photo of Marian Kocmanek

Marian Kocmanek, Official Rep

  • 441 Posts
  • 86 Reply Likes
Hello Martin, 

Thank you for reporting this issue. I have forwarded this post to our Quality Assurance Team for review and will circle back when this issue has been addressed. 

Thanks, 
Marian
Photo of Alexey Lelyuk

Alexey Lelyuk

  • 5 Posts
  • 0 Reply Likes
Hello Martin,

Which application did you use to create this template? Could you send your map to investigate the issue.

Thanks,
Alex