Categories semicolon separated instead of comma

  • 1
  • Question
  • Updated 4 years ago
Hi all,

is there a way to tel mindmanager that my outlook 2013 in win7 uses ";" as separator for categories instead of "," of the english version?

I found searching in this community that this is the reason why I have the following problem:

When importing from outlook, mindmanager sees tasks marked with more than one category as a unique category.

i.e. let's say I have a task in outlook marked with the following 2 categories: "clientA" and "administration". When I import from outlook to mindmanager, the category of the topic is "clientA;administration". And in the index there is only 1 category "clientA;administration". So I can't properly filter for categories.

Obviously the correct behaviour would be recognizing 2 separated categories...

I could apparently solve changig the region settings in Win7 but it creates problems using excel when managing csv files, since in numbers decimals in the italian version are separated by a comma i.e. 1.35 (1 point 35) is 1,35 in italy.

So, is there in mindmanager a solution for this? Maybe a voice in preferences (I did not find that) or a macro.

Thank you for your support.
Photo of ruber

ruber

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Nick Duffill

Nick Duffill, Champion

  • 505 Posts
  • 168 Reply Likes
Hello Ruber

MindManager should be able cope with this. For task resources, it will automatically use a semicolon to separate resource names if the names contain a comma (e.g. "Smith, John"). If categories are written by the API using a semicolon, MindManager 14 correctly converts into two tags. I can only guess that this is a bug in the Outlook sync.

Based on this, the following script might work to convert categories of the form "a;b" into separate tags. It is worth a try anyway.
Sub Main
    Dim m_Topic As Topic
    Dim s_1 As String
    For Each m_Topic In ActiveDocument.Range(mmRangeAllTopics)
        s_1 = Trim(m_Topic.Task.Categories)
        If Len(s_1) > 0 Then
            m_Topic.Task.Categories = ""
            m_Topic.Task.Categories = s_1
        End If
    Next
End Sub
Photo of Alex Gooding

Alex Gooding, Champion

  • 827 Posts
  • 207 Reply Likes
This has been a problem for several years in syncing Outlook categories with MindManager, dating back to the days when Mindjet decided to remove the custom categories text tag group in the upgrade from 8 to 9. At least they left the current limited facility to sync, but it has only ever worked if commas are set as the separator for CSV files in the region settings.
Photo of ruber

ruber

  • 2 Posts
  • 0 Reply Likes
Hi Nick and Alex, thank you for your support.

@Nick: your solution is almost perfect! So far, the script separates the categories and ADD these to the original string.
i.e. "clientA;administration" becomes "clientA, administration, clientA;administration". Is it possible to keep only "clientA, administration"?

Thank you. :-)