Default browser

  • 1
  • Question
  • Updated 3 years ago
Is it possible to set option - default browser? i would like to open all links in Google Chrome. 
Photo of Seva

Seva

  • 18 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Nigel Goult (Olympic & MIVAP)

Nigel Goult (Olympic & MIVAP)

  • 347 Posts
  • 133 Reply Likes
If you want to open links clicked in MindManager Maps in your systems default browser then from the Link command on the Home ribbon menu make sure the Use Built-in Browser for Links option is unchecked as below.


Regards
Nigel

MAP for MindManager - more than 37 new functions taking MindManager to the next level. Become a MindManager Power User with MAP. Now with extended license plans for Enterprise and Education - Learn more at www.mapformindmanager.com
Photo of Kyle Krom

Kyle Krom

  • 2 Posts
  • 0 Reply Likes
What if I need to use two different browsers? Some of our URLs are designed specifically for Internet Explorer, and others for Chrome. How do I get each hyperlink to open in the corresponding browser?

I have already tried: 
1. Hyperlink directly to the browser executable (e.g. C:\...\chrome.exe) and specify the URL as an option. Although this works in the full Mindjet client, it does not work in a map published via the Sharepoint plug-in because hyperlinks to local files are not supported. Presumably the same problem would also affect maps exported to PDF, though I haven't tested it.
2. Hyperlink to a batch file: same problem as above
3. Solving the problem outside MM: for example, setting Chrome as the default browser and using Chrome's "IE Tab" plug-in to change the rendering engine for certain URLs. Unfortunately, our IT department in their infinite wisdom have blocked our ability to add Chrome extensions.

Any other ideas?

Kyle
Photo of Tom Hankins

Tom Hankins

  • 2 Posts
  • 0 Reply Likes
Yo Kyle,

I was working on this problem too.  Ok, so what I did was I created a shortcut file.

1.  Find a place you want to keep your shortcuts and create a folder for them.  I called it, ever so creatively, "shortcuts."
2. Right click in the empty folder and select "New" then "Shortcut"
3. Follow the prompts put the path to the browser you want to use first then the URL like this:
"C:\Program Files\Internet Explorer\iexplore.exe" https://www.blahblah.com/reallylongseriestofcharactersnumberslettersandsymbolsbecausesharepoint/inde...
4.  Name it.
5. Save it.
6. Drag it into Mindjet.  

I added as a file on the topic and it even pops it out of MindJet even though the Use Built In Browser thing is enabled.

Let me know if it works for you.
Photo of Kyle Krom

Kyle Krom

  • 2 Posts
  • 0 Reply Likes
Thanks for trying, but unfortunately the result is the same as I described above. It works from the Mindjet client, but when the map is published via the Sharepoint plugin: "Hyperlinks to local files are not supported". 
Photo of Marian Kocmanek

Marian Kocmanek, Official Rep

  • 364 Posts
  • 64 Reply Likes
Kyle, 

The Mapping canvas in the SharePoint plug-in, formally known as MindManager Server is Flash based. Flash instances are sandboxed and do not have access to the Windows File Explorer and thus, cannot resolve the link. What you can do is upload the attachments to a SharePoint document library, then update the Topic Hyperlinks in your Map with URL's pointing to those items. The links should then resolve without issue. 

I hope that helps. 

Best, 
-Marian
Photo of Tom Hankins

Tom Hankins

  • 2 Posts
  • 0 Reply Likes
Dang!  Does the shortcut on its own work?  Not in or from MindManager but from just the desktop?