Excel slow to open recent files rfom task bar when mindmanager 17 loaded

  • 1
  • Problem
  • Updated 10 months ago
first off 2nd time had to type this because of crappy logging system.

when mindmanager is open any excel file opened from the task bar recent files takes over 30s to load.

close mindmanager and problem goes away

mindmanager 17 windows 10, office2016
Photo of Chris Atkinson

Chris Atkinson

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of aHa!Coaching

aHa!Coaching, Champion

  • 1192 Posts
  • 115 Reply Likes
Hmm, could you maybe check if your system is busier than normal or using more memory than normal when both Excel and MindManager are open? Navigate to the Start Menu and type in 'Task Manager' at the bottom of the menu (if you're on an English version of Windows, that is)
Photo of jmbolivar

jmbolivar

  • 5 Posts
  • 0 Reply Likes
Exactly the same problem here, same configuration too.
Photo of Keith

Keith

  • 1 Post
  • 0 Reply Likes
Same problem here. Also clicking on attached document does not automatically open the Browser, have to click the Tab to see the preview
Photo of Sia Banihashemi

Sia Banihashemi, Official Rep

  • 95 Posts
  • 28 Reply Likes
Our team is investigating this issue. We'll post an update about this as soon as we have more information. Please reply with the bit version of MindManager you are using (32bit or 64 bit) found under File/Help. Thanks! 
Photo of jmbolivar

jmbolivar

  • 5 Posts
  • 0 Reply Likes
64 bit
Photo of aHa!Coaching

aHa!Coaching, Champion

  • 1192 Posts
  • 115 Reply Likes
I did some further testing and I seem to have the same issue on Windows 10 64-bit, MindManager 2017 64-bit and Excel 2016 64-bit. With MindManager open it takes 25 seconds to open a file, without MindManager it takes 5 seconds. I thought it was related to Windows running in Parallels, but it seems to be related to MindManager?
Photo of jmbolivar

jmbolivar

  • 5 Posts
  • 0 Reply Likes
Exactly same setup and same issue. I only experience it with Windows 10 64-bit + MindManager 2017 64-bit + Excel 2016 64-bit
Photo of CarpeDiem

CarpeDiem

  • 2 Posts
  • 0 Reply Likes
I have exactly the same problem on Windows 10 64bit but with MindManager 17 32bit and Excel 2013 32bit. I guess the problem is independent of the bit-with of MindManager/Excel.

Photo of Shilpa Kabra

Shilpa Kabra, Official Rep

  • 125 Posts
  • 31 Reply Likes
Hi All,

We have opened a defect on this with engineering.
One thing I would like all of you to verify that is you guys are experiencing issues from File--> recent ?

Thanks,
Shilpa
Photo of jmbolivar

jmbolivar

  • 5 Posts
  • 0 Reply Likes
In my case it is not from File --> recent but from the recent files that pop-up on the Aero view from the Excel icon in the taskbar. From File--> recent, once Excel is open, it works as expected, with no issues.
Photo of aHa!Coaching

aHa!Coaching, Champion

  • 1192 Posts
  • 115 Reply Likes
Looks like the delay isn't there on my system when Excel is already open, so File --> Recents works without delay.
Photo of CarpeDiem

CarpeDiem

  • 2 Posts
  • 0 Reply Likes
The delay happens when I open Excel by double-clicking on an Excel file. If MindManager is running it takes about 20s to open Excel, if MindManager is not running, Excel opens immediately.
Photo of Alexis Grzes

Alexis Grzes

  • 2 Posts
  • 0 Reply Likes
I experience the same problem as CarpeDiem.

If MindManager is running, opening an Excel file from explorer takes about 20s.
When MindManager is not running, it opens immediately.
If Excel is pre-loaded and mIndmanager is running, it opens immediately.

I've made different tests:
- I've disabled extensions in Excel (COM Complement MM) an MindManager (Excel linker). The problem is the same. I've noticed that it points to the same DLL. Don't know if it matters.
- I've uninstalled Excel add-in in MindManager -> same problem
- I've repaired Mindmanher installation -> same problem
- I've repaired Office 2013 installation -> Same problem

After a click on an excel file, I went to MindManager and exits from it -> Excel file loads immediately

I'm using Windows 10 64-Bits, MM17 64bits and office 2013 64 bits
Photo of MichelT

MichelT

  • 8 Posts
  • 1 Reply Like
Exactly the same problem with Window 7 64bits Mindmanager 17 32bits office 2010 32bits
Photo of Ary Velstra, Expert Trainer

Ary Velstra, Expert Trainer

  • 1232 Posts
  • 181 Reply Likes
We have seen lots of posts about issues that appear when using mixed bit versions of Windows and office / mindmanager . Please adjust that first It may do wonders
Photo of Alex Gooding

Alex Gooding, Champion

  • 827 Posts
  • 208 Reply Likes
I'm wondering also if MM2017 may be a bit of a memory hog. I haven't experienced this particular Excel problem yet, but I am getting a few low memory warnings when running MM 2017 32-bit with a few maps open and several other programs also open (not just Excel), especially if those programs have multiple tabs. I'm running Windows 10 and the computer has 8gb of RAM; interestingly my wife who has virtually the same computer but with 12gb RAM does not experience the same problem.
Photo of aHa!Coaching

aHa!Coaching, Champion

  • 1192 Posts
  • 115 Reply Likes
FYI, to clarify this case: this seems not be related to 32-bit/64-bit mixes as this happens on full 64-bit as well and also this is not something that seems to be memory related as the amount of maps open (or even no map open) does not seem to impact the time it takes to open Excel.
Photo of Matthias Luger

Matthias Luger

  • 1 Post
  • 3 Reply Likes
Hi all,


i have a workaround for this problem.

for me it works if i run MindManager2017 as administrator.
I set this in compatibility settings of the MindManager2017-link on my desktop
So word and excel start in view seconds.

i also disabled the compatibility assistant from windows 10 because after closing MindManager i get a message from the assistant.
http://windowsten.info/forum/compatibility/software-compatibility/267-windows-10-disable-program-com...

if you use mapped network drives you have to add a value in the registry
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System 
add a new DWORD (32 Bit) named EnableLinkedConnections and set value to 1
reboot and now use your network-drives as administrator


i hope i can help somebody.

Photo of Sia Banihashemi

Sia Banihashemi, Official Rep

  • 95 Posts
  • 28 Reply Likes
That's great Matthias! Thanks for your contribution.
Photo of Jan Königsmark

Jan Königsmark

  • 1 Post
  • 1 Reply Like
Hello, thanks, the same issue, running MM as Administrator solved.
Photo of Ary Velstra, Expert Trainer

Ary Velstra, Expert Trainer

  • 1230 Posts
  • 181 Reply Likes
Maybe someone at Mindjet could place a SOLVED mark on this thread
Photo of jmbolivar

jmbolivar

  • 5 Posts
  • 0 Reply Likes
As stated by Matthias, having to run MM as Administrator is a workaround, not a solution. I wouldn't say this is «solved» at all.
Photo of Laurent TORLOIS

Laurent TORLOIS

  • 1 Post
  • 1 Reply Like
hi,
this post is old but if it can helps, the problem is solved for me?
first sorry for my english, i'm french;
so :
1/ my environment : same problem with pcs on windows 7 10 mindminager 2017 with excel 2010
pcs are in domain,
users are "simple" users not administrators (but the problem is the same with an administrator account)
files on local computer or network

2/ resolution :
- open the registry
- save the key (and subkey) HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\open
- delete all in open
that means HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\open\command and ddexec
- do the same for the branch HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\open

note : the excel.sheet.12 is for xlsx files
and excel.sheet.8 is for xls files
3/ reassign the files :
right clic on a xlsx file, "open with", find and select excel.exe
do the same for the xls files

tested on several computers : all is good for me

i don't know if it works for office 2013 or 2016

thanks