How do I prevent topics from renumbering when I filter a map?

  • 1
  • Problem
  • Updated 5 years ago
I have a large map with numbered topics/subtopics. When I filter the map using applied icons or priority icons, the numbering automatically is redone. I don't want this. I want the numbers to stay as originally assigned for the entire map.  Can I prevent this from happening, other than having to go back and manually renumber the entire map?
Photo of Bill Riski

Bill Riski

  • 1 Post
  • 0 Reply Likes
  • A bit frustrated.

Posted 5 years ago

  • 1
Photo of Alex Gooding

Alex Gooding, Champion

  • 874 Posts
  • 220 Reply Likes
There was a thread on this question about a year ago: https://community.mindjet.com/mindjet/topics/i_would_like_to_keep_the_numbering_of_my_items_the_same...

Mindjet indicated that they would consider the suggestions that were made in that thread, for example, the ability to include or exclude filtered topics on a per-map basis and a facility to include or exclude numbering for specific topics and their branches.

Unfortunately they have not included either facility in subsequent releases. However Nick Duffill posted in the above thread some instructions for a great workaround, based on a little macro he created (the link is in his post).

This embeds the automatic topic numbers into the text of the topic, after which you can filter the topic at will without these numbers changing. When you have finished you can turn off all filters and run the macro again to remove the embedded topic numbers. You can then reapply automatic numbering.

I'd forgotten about this until your post reminded me. I've downloaded the macro and although it was written for MindManager 10 it works a charm in MM14, so it should be fine in Mindjet 11.