How to disable the alt key?

  • 1
  • Question
  • Updated 6 years ago
  • Answered
Alt key shows shortkeys to menus. Problem is, focus is on these then. And this means that within commands where the shortkey is a combination including the alt key, focus is transferred to the menu, and no further command execution, a second or third time, is possible. Example: Move an item up or down, shortkeys control-alt-arrow, you can do it exactly 1 time, and then focus is within the menu, so no shuffling up or down an item 2 or 3 times in a row is possible. My question: How to avaid this behavior, for example, how to disable the alt key accessing the menu?
Photo of Pierre

Pierre

  • 1 Post
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Michael Deutch

Michael Deutch, Official Rep

  • 438 Posts
  • 76 Reply Likes
Hi Pierre, if you hold the control and alt key down, you can use the arrow keys multiple times. If the alt key happens to select the menu because you clicked it first, then you can click the alt key again to deselect the menu. Does this answer your question?
Photo of Pierre

Pierre

  • 2 Posts
  • 0 Reply Likes
Thank you, Michael, but the problem goes deeper. Often, I can trigger the command several times, then again only one time, since the focus has gone into the menu, it's unpredictable. And with macros, it's outright impossible. Macro would be to have num7 = move up and num4 = move down, control-alt-arrowUp/Dn respectively. And even when I do it very precisely, by hand, holding down control, then only holding down alt (and then wanting to press the corresponding arrow key), the moment the alt key is pressed (even when the control-key is already held down), the menu short keys appear on the screen, and the focus has been shifted to the menu. Then, I have to click with the mouse within the map in order for the focus to revert back, and then only I can proceed with the command.

It seems control-key and alt-key have to be pressed within the same millisecond in order to prevent this, as said, when I press control, hold it down, then press alt, the damage is done.

Thus my question: Is there a secret option, a registry tweak or such, in order to prevent the alt key from triggering the menu? I don't need the menu but here and there, but all these key combinations for moving, I use them all the time, and so often with problems.

MM, now MJ, offers these fine commands that are not present in competing software, so in theory, I'm very happy with this, but those constant problems invalidate these fine commands to a degree.

So, is there a solution, work-around, anything to prevent the menu shortkeys popping up?
Photo of Pierre

Pierre

  • 2 Posts
  • 0 Reply Likes
I would like to add two things: Even by hand, it's totally unpredictable. Many times, pressing and holding down control, then pressing alt, will NOT show the menu shortkeys, and then again, it does it, again and again - there is no system in this phenomenon showing or not.

And then, I do NOT speak of MM9 for Mac, but for Win! It seems I checked the wrong checkbox there. So it's a Windows problem, not a Mac problem. Any registry tweak, please? (If I cannot use the menu shortcuts afterwards, no problem.)
Photo of Michael Deutch

Michael Deutch, Official Rep

  • 438 Posts
  • 76 Reply Likes
Hi Pierre, it sounds like there is a bug and it may be due to configuration issues. I haven't experienced the scenario that you described on my machine. Can you submit a ticket with our support team? https://secure.mindjet.com/support/co...

Thanks,
Michael

This conversation is no longer open for comments or replies.