Is it nearly impossible to add a "New Post" here, or is it just me?

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)

I just spent over 30 mins trying to post to here in using Google Chrome browser. It kept accepting my passwords but not actually letting me post. I tried using my Google account, I tried using it even allowed me to log into getsatisfaction... 

Eventually I only succeeded by doing exactly the same sequence of steps but using the Opera browser.  [GRRR]

Deeply frustrating. 


Photo of John Smith

John Smith

  • 158 Posts
  • 6 Reply Likes
  • frustrated

Posted 7 months ago

  • 1
Photo of John Smith

John Smith

  • 158 Posts
  • 6 Reply Likes
UPDATE: I have now managed to log in using Firefox, but still not with Chrome.
Photo of Blair Young

Blair Young, Official Rep

  • 26 Posts
  • 15 Reply Likes
Hey John - thanks. That is interesting. I use Chrome to log in as do most of my team. I am unsure of the issue but do apologize. One thing I will mention is that this is an aging platform and we are currently looking to move to a more current platform sometime in 2020. I will mention this to support and see what they can suggest. Cheers... Blair
Photo of Ary Velstra, Expert Trainer

Ary Velstra, Expert Trainer

  • 1829 Posts
  • 308 Reply Likes
Hi Blair,
If you are moving to a new platform please do not forget to import all helpful responses that is in here.
I use it a lot as reference.
Thanks for considering.