Mindjet for iphone on iOS 11.0 does not work well

  • 1
  • Problem
  • Updated 10 months ago
  • Solved
Mindjet for iPhone was removed from my iPhone in June as it was a 32 bits app and therefore at the time not compatible with iOS 11 betas. Yesterday, after installing the release of iOS 11.0 Golden Master, the app is downloadable again. I lost all my creations though and the app does not work as it should. Where is the button to add a new app? Sometimes I need to go back to the previous screen, where’s that button? I can’t import old creations that I have sent by email. :-( I really loved this super app, it worked so great and intuitively, but right now it is not good. It crashes now and then. I hope you can fix these problems.
Photo of rutger oonk

rutger oonk

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 10 months ago

  • 1
Photo of Marian Kocmanek

Marian Kocmanek, Official Rep

  • 364 Posts
  • 64 Reply Likes
Hello Rutger, 

Thank you for reporting this issue. We have identified a fix for the issues  and are submitting an update to the Apple App store. As for the maps you previously created, if they were not saved to a cloud service such as Mindjet Files, Dropbox or Box, they would of been deleted when you uninstalled the App in June.