MindManager 2020 silently dies after start

  • 1
  • Problem
  • Updated 8 months ago
I've tried different versions of MindManager, but can not start version newer than 2017. I've tried 2018/2019/2020, all with same behavior. When I start application nothing happens. When I start under debugger I can see System.TypeLoadException in GoogleAnalytics.Core.dll (see screenshot). The message is: cannot load type "System.Timer" from "System.Threading.Timer, Version=, Culture-neutral, PublicKeyToken=b03f57f11d50a3a". I've tried reinstalling .NET Framework and MindManager several times. I've also posted ticket #00487917, but mindjet support cannot help me...

Photo of muxx muxx

muxx muxx

  • 12 Posts
  • 2 Reply Likes
  • confused

Posted 8 months ago

  • 1
Photo of Ary Velstra, Expert Trainer

Ary Velstra, Expert Trainer

  • 1892 Posts
  • 339 Reply Likes
Strange....Are you sure you have the correct license keys for MM2018, 2019 and 2020?
They are not the same.
And have you entered those in the right place (see help => license key)