MM2012 removes leading spaces in text notes

  • 2
  • Problem
  • Updated 6 years ago
  • Solved
Hi,

When I write text notes in MM2012 with lines containing double leading spaces, it looks ok the first time. But when I save the mmap, and open it again, the first leading space of each lines (beginning with double spaces) have been removed! Since I use the software to write configurations, it becomes difficult to read.

The first time:

!
serverfarm SFARM01
real SERVER01 9080
inservice
real SERVER02 9080
inservice
probe PROBE01
end
!


Close the topic note, save the mmap and reopen the note:

!
serverfarm SFARM01
real SERVER01 9080
inservice
real SERVER02 9080
inservice
probe PROBE01
end
!


I did not have this issue with MM7.2.

Is there an option to tell MM not to change the formatting of the text notes, or is this a bug?

Thank you.
Photo of Eric

Eric

  • 5 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 2
Photo of Andrew Wilcox

Andrew Wilcox, Champion

  • 1033 Posts
  • 177 Reply Likes
There were some improvements to the Notes editor in the latest version of 2012 10.1.459.

I am not aware of any options to control text formatting. You could check there is no double space autocorrect in the File > Options settings
Photo of Eric

Eric

  • 5 Posts
  • 0 Reply Likes
Hi Andrew,

Thank you for your reply.

I'm already running the latest version of MM2012 (10.1.459) and I don't see any settings in File > Options related to double space auto-correction :(

How can I submit a bug to the developer team? This problem is really critical for us, because some notes/configurations are unreadable.

As I said previously, we didn't have this issue with MM7.2.
Photo of Alex Gooding

Alex Gooding, Champion

  • 872 Posts
  • 220 Reply Likes
That's interesting - it also occurs to double spaces in the middle of the line as well.

I'm just guessing, but the automatic removal of double spaces may have been introduced to deal with another bug in MM8 or MM9, where unwanted double spaces would appear randomly in topic notes. If this is the case then this is a very clumsy fix.

In the meantime, (and I know this is also a bit clunky) would it be possible to substitute a character that isn't used elsewhere in the configuations for the first space in a double space?
Photo of Andrew Wilcox

Andrew Wilcox, Champion

  • 1033 Posts
  • 177 Reply Likes
Hi Eric

Did you look at Options > Spelling > Autocorrect and Custom Dictionaries ?
I can't see any evidence of entries that would do this is in mine and I get exactly the same effect as you describe above.

I agree with you that the Notes Editor is a clunky 10 year old word processor which has never received the attention and updates from Mindjet that it needs for those who use MindManager as part of their web site, documentation, coding and writing production processes.

The previous 2012 version introduced errors that had never existed i.e. removing spaces or removingspaces! This version has fixed that and the long term error of adding random spaces or adding random spaces.

As you can detect I am very unhappy with the Topic Notes Editor.

The MindManager Topic Notes Editor - Time for a big change
Photo of Eric

Eric

  • 5 Posts
  • 0 Reply Likes
Alexsg: Unfortunately, it is not possible to use an other character.

Andrew: I looked at the Autocorrect Options, but the list is empty, and I've seen nothing that would to this behaviour in the Custom Dictionaries.

Like you, I'm very disappointed with the Topic Notes editor. I hope Mindjet will fix this problem soon, because the upgrade from MM7.2 to MM2012 is a waste of money for us.

Thank you again for your help.
Photo of Alex Gooding

Alex Gooding, Champion

  • 872 Posts
  • 220 Reply Likes
Eric - Looking back at my previous comment I realise I didn't explain my suggestion properly, though it probably won't make much difference.

I was assuming that you may export the software configuations to something that has some sort of search and replace facility. If that was the case, you could set up something like "#space" or even "##" instead of two spaces, then after exporting the note you could search for and replace all instances of this combination with a double space.
Photo of Nick Duffill

Nick Duffill, Champion

  • 512 Posts
  • 170 Reply Likes
This is probably a side-effect of using XHTML to store the topic notes. HTML normally collapses multi-character white space to a single space. I believe MindManager already uses non-breaking spaces internally to signal text wrapping, so stores user-entered spaces as regular white space, meaning it gets a bit of HTML treatment.

A prize-winningly ugly workaround is to set your keypad to NumLock and enter Alt+0160 for spaces that you want preserved. A hot key macro utility might make this quicker to use in practice. However, this might have unintended consequences for other export formats or copy & paste to other environments.
Photo of Eric

Eric

  • 5 Posts
  • 0 Reply Likes
Anyone know how to submit a bug to the developers? My initial post was sent about 1 month ago, and still no response from the Mindjet team...

Thank you Andrew, Alexsg and Nick for your tips. Unfortunately, it is not possible for us to use another character (like "#space" or even Alt+0160). We have tried, but the copy/paste doesn't work properly on the network equipment.
Photo of Andrew Wilcox

Andrew Wilcox, Champion

  • 1033 Posts
  • 177 Reply Likes
Photo of Eric

Eric

  • 5 Posts
  • 0 Reply Likes
Thank you Andrew.

Mindjet Case # 00242381

This conversation is no longer open for comments or replies.