MM 2012 Pro does not export correctly to Word

  • 2
  • Problem
  • Updated 6 years ago
  • Solved
When you select a Word Template for your export, e.g. Normal.dot, then the Topic level styles chosen (E.g. Heading 1) is not used, but all levels get assigned a Style called MM Topic 1, MM Topic 2 and so on for the different leves.

It is quite annoying since you then manually have to change styles aftwards. Is there a solution for that?
Photo of Morten Høgholm Pedersen

Morten Høgholm Pedersen

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 2
Photo of Alex Gooding

Alex Gooding, Champion

  • 842 Posts
  • 211 Reply Likes
Have a look at Olympic Limited's OPTi-Word: http://www.olympic-limited.co.uk/opti...

Unlike MM's Word export, OPTi-Word uses Word's own templates and styles, any one of which which you can select. You can also choose which style to use with individual topics, irrespective of the topic level; for example, you can apply a level 2 Word heading style to a level 4 MM topic, or vice versa.

If you want to continue using MM's Word export it may be possible to set up a macro in Word to replace the MM template styles with their equivalent in the equivalent Word template.
Photo of David Baril

David Baril

  • 8 Posts
  • 0 Reply Likes
Hi Morten,

I think I got it working ... at least in a usable way.

When you first export to MS Word, make sure that you select "Use Settings from template". Do NOT select "Use custom settings:".

This means that the indentation and numbering/bullet scheme will come from your template. If you want numbering and indentaton, make sure that your styles have those attributes defined.

On the "Word Template" tab, select your template file. Choose "User" and then select your personal Normal.dotx file. A typical location is:
C:\Users\{userid}\AppData\Roaming\Microsoft\Templates\Normal.dotx

If you try to select "built in", you wll find that the folder that MM2012 positions the file selection browser pane to ... does NOT have a Normal.dot or Normal.dotx file located in it.

If you cancel out of the file selection browser pane, the template name "Normal.dot" is shown in the entry field .... but which one? I don't know what template MM2012 will use at this point .... but it is not yours.

If you properly selected your template Normal.dotx file, the long path will be displayed in the "Word template" field.

In the "Style Mapping" section of the pane, there are pull down selection options. Try changing one... and look at the list of the available styles ... and you can see that styles contained in your personal template ARE listed. You might want to create a style with a unique name, just to verify this. (I did).

Select whatever other export options you want, and let the export run.

The resulting MS Outline will have styles "MM Topic 1", etc ....but the style definitions are LINKED to the style in your personal Normal.dotx template. For example, if you have "MM Topic 1" set to "Heading 1", the MM style will be linked to your personal "Heading 1" style. This ONLY works if you had the proper "User" template selectiion ... with the full long path showing in the previous "Word template" entry field.

If you open the MS Word document, and change the definition of "Heading 1", the linked style of "MM Topic 1" will also change. So, the "MM Topic 1", "MM Topic 2", etc styles are effectively aliases to your personal styles "Heading 1", Heading 2, etc.

If you had selected "Custom" numbering and indentation (which I told you NOT to), you would find that the "MM Topic 1" style definition would still be linked to "Heading 1", but it would also override the indentation and numbering of the "Heading 1" style, which is probably what you DON'T want.

This works for me.

It gives me my personal styles that I want, but puts a "MM" name wrapper over it by linking to the personal style. So it looks like you have duplicate or redundant style names, and you do. But you have the added flexibility, that if you need to, you can modify the "MM Topic 1" style without changing the "Heading 1" base style. These changes to the "MM Topic 1" style will propigate to all the "MM Topic 1" lines, and NOT the "Heading 1" lines. If you want to change both the "MM Topic 1" and "Heading 1" style, change the base "heading 1" style, and both will change, since "MM Topic 1" is linked.

Also remember you can run the style organizer to move style definitions from the local document to/from the global template.

I hope that this helps. 4 KEY steps
1) Select "Use settings from template" for the numbering and indentation
2) Make sure that the LONG path to your normal.dotx file is listed in the "Word Template" field. If not some internal style defaults are used.
3) Realize that the "MM Topic 1", -type styles are just LINKs to your styles with a different names.
4) Modifications to your personal base style such as "Heading 1" will cause "MM Topic 1" to automatically follow (assuming you select "change all occurances").

Dave B
Photo of David Baril

David Baril

  • 8 Posts
  • 0 Reply Likes
Update/correction to my answer

MM2012 does NOT properly use your custom MS Word Normal.dotx template and your custom styles for "Heading 1", "Heading 2" etc.

THIS IS A BUG.

If you follow my post above, you do create a working outline document, that has the Mindmanager styles "MM Topic 1" , etc, liked to "Heading 1", etc.

The problem is that MM2012 used the INCORRECT definition for "Heading 1", etc.

There is a simple workaound.

Take your exported outline document, and open in with Word.

Theses are the commands for Word 2010....

Open the style selector "CTRL-SHIFT-S"

select the "Styles" button (with double A icon). The Style selector pane will be displayed.

Select the right-most style button on the bottom "Manage Styles". The "Manage Styles" pane will be displayed,

Select the Import/Export button. The "organizer" pane will be displayed.

On the right-hand side, it shows the styles in your Normal.dotm template.

Shift-select the first style on the right, scroll down to the end, shift-select the last style. The region will turn blue when selected.

select the "Copy" button in the middle.

Answer "Yes to All" when asked if you wish to override the existing style.

That will update all the base styles "Heading 1", "Heading 2", etc, in your exported MindManager outline document.

Select the "close" button on the organizer pane,

Now you will be back to your outline, and the styles and indentation should reflect your custom styles from your normal.dotm template.

Since all the MindManager styles, like "MM Topic 1", are linked to their respective baseline styles, when you replaced the baseline styles above, the MM styles will automatically change to reflect the target style.

Save your exported outline to update the style definitions.

So MM2012 still does NOT correctly use your custom styles on export, but it is relatively easy to complete the processes.

I have tested this and it works properly on my MM2012 install with MS Word 2010.

Dave B.
Photo of Morten Høgholm Pedersen

Morten Høgholm Pedersen

  • 3 Posts
  • 0 Reply Likes
Thanks - but a bit to much work to make it useful.

Do you know how to get attention to get that fixed? Just got the latest version 11 update to Mindjet and the bug is still there.

I always wanted to use MindManager to create the synopsis for documents, but since the mapping does not work it cannot used very efficiently :-(

kr
Morten
Photo of Alex Gooding

Alex Gooding, Champion

  • 842 Posts
  • 211 Reply Likes
@Morten,

Did you have a look at OPTi-Word?
Photo of Mick Jones

Mick Jones

  • 89 Posts
  • 8 Reply Likes
just FYI
Olympic (Opti-word) and amother company did a collaberation project to create the next level "word4maps" . it allows you to use word formatting within Maps to create what you want. it can also integrate with Opti-word if you have it.
The Collaberation was called MODI... http://www.word4maps.com/
Photo of Alex Gooding

Alex Gooding, Champion

  • 842 Posts
  • 211 Reply Likes
Yes I forgot to mention Word4Maps. To add to Mick's description this enables full Word formatting within topic notes and as he notes it works quite well with OPTi-Word.

I'm very happy with this combination but you should have a look at the trial version for both products first - there are some little quirks to the way each add-in works but more importantly you need to see if they suit your style of working.

This conversation is no longer open for comments or replies.