Opening .doc hyperlinks with LibreOffice

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
I make great use of Mind Manager for project management, with topics hyperlinked to documents. By default I use LibreOffice, with Windows XP set up to open anything with a .doc suffix in LibreOffice.
However, Mind Manager 2012 consistently opens .doc files with Microsoft Word; (it also shows the Word icon, whereas in Windows Explorer the LibreOffice Writer icon is displayed).
Is there any way I can get MM2012 to do what I want, please?
Photo of Chris Bishop

Chris Bishop

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Nick Duffill

Nick Duffill, Champion

  • 512 Posts
  • 170 Reply Likes
Chris

Does it make a difference if you right-click on the link and choose "Open hyperlink outside MindManager"?

This is only a guess, but try comparing the file associations in Windows Explorer with those in Internet Explorer. MindManager might be using Internet Explorer settings. I don't know if it is possible for them to be set differently, but it is worth checking.
Photo of Chris Bishop

Chris Bishop

  • 6 Posts
  • 0 Reply Likes
Nick,

Thanks for your suggestions. Opening the link outside MM doesn't make any difference: the .doc files still open in Word.

Opening the file in IE8, however, also opens the files in Word, so your second suggestion may be helpful. Unfortunately, I cannot find out how to alter the file associations that IE uses - any ideas?

Chris
Photo of Nick Duffill

Nick Duffill, Champion

  • 512 Posts
  • 170 Reply Likes
Chris

In IE 8: "Tools" button (gear wheel icon) > Internet Options > Programs tab > Set Programs > Associate a file type or protocol with program
Photo of Chris Bishop

Chris Bishop

  • 6 Posts
  • 0 Reply Likes
Nick,

I'm not sure whether I'm being stupid, but when I get as far as the Programs tab, I only have three sections there: Internet programs, Default web browser, and Manage add-ons. There's no sign of 'Set programs'.

Chris
Photo of Nick Duffill

Nick Duffill, Champion

  • 512 Posts
  • 170 Reply Likes
Hello Chris

This is what I am seeing in my copy of IE8. If you do not have the "set programs" button, maybe it is something to do with account permissions. You could try right-clicking on the IE8 desktop icon or start menu command and selecting "Run as Administrator" - that might help if this is the reason.

Photo of Chris Bishop

Chris Bishop

  • 6 Posts
  • 0 Reply Likes
Nick,

The plot thickens... This is what I see:


I don't think I mentioned, (if it has any bearing on the issue), that I'm running Windows XP SP3 (32 bit) with Windows Update keeping me up to date. I normally use Chrome as my web browser. IE is 8.0.6001.18702.

I'm the only user of my PC and I am the administrator, so I can only open IE as an administrator.

Thanks for your continued suggestions!

Chris
Photo of Nick Duffill

Nick Duffill, Champion

  • 512 Posts
  • 170 Reply Likes
Chris

I owe you an apology - the screen shot I sent was from IE9, not IE8. I had checked it on the wrong system. Doh. You are right, IE8 does not appear to offer this level of control. Unless you have the inclination to install IE9 instead of 8, have you tried the advanced settings for the file type association in Windows Explorer? In addition to setting the programme associated with the file type, there is also an Advanced button that sets the DDE syntax used for various verbs (actions) on the file type such as open, print, new and so on. I wonder if these get updated if you modify the basic programme association, and if not, whether IE and MindManager use DDE to launch the application.

Windows Explorer > Tools > Folder options > File Types > "Doc" > Advanced > "Open" > Edit... does this point at the right application?
Photo of Chris Bishop

Chris Bishop

  • 6 Posts
  • 0 Reply Likes
Nick,

Still no joy, I'm afraid. I've been fiddling around with the Folder Options in Windows XP, and everything but MindManager opens .doc files with LibreOffice, as the file associations would predict. I've also tried hyperlinking to .xls and .ppt files from MM and in both cases the files open in the appropriate LibreOffice application. I conclude, therefore, that Mind Manager handles .doc files differently.

I also tried your Windows Explorer Folder options suggestion in your last post, but when I get as far as selecting 'doc', the 'Advanced' button is replaced by a 'Restore' button. I tried 'Restore' (which brought back the 'Advanced' button) and then 'Advanced' and set the DDE Open command to use the LibreOffice swriter.exe program, but this wasn't successful.

I also tried deleting the .doc extension in Folder Options and re-creating it with document type OpenOffice text, but, while this worked find outside MM, once again MM opened it with Word.

I suppose the Windows Registry could be now thoroughly confused....

Any other ideas? If not, I guess I'll just have to live with it.

Chris
Photo of Nick Duffill

Nick Duffill, Champion

  • 512 Posts
  • 170 Reply Likes
Chris

I am about out of ideas. The worst case scenario might be that MindManager has built-in handling for Office documents, but I don't think that is likely.

Have you tried reinstalling or repairing MindManager after installing LibreOffice? Maybe it picks up some information from the registry at install time.
Photo of Chris Bishop

Chris Bishop

  • 6 Posts
  • 0 Reply Likes
Nick,

I think I've found the solution! If I deselect the 'Microsoft Word Import and Export' Add-in option, .doc files open happily in LibreOffice. Re-enabling the option reverts to the previous (unwanted) behaviour.

I do hope this isn't the 'blindingly obvious' solution. Until I tried it, I'd assumed that it only applied to things like saving files as Word, or importing Word files as maps, and my reading of the Help text does nothing to dissuade me from that belief. However, if it works, who am I to quibble?

Thanks very much for your persistence in this issue - your help has been much appreciated.

Chris
Photo of Nick Duffill

Nick Duffill, Champion

  • 512 Posts
  • 170 Reply Likes
Well done Chris - I would not count that as blindingly obvious, as it implies that the import/export Add-in enforces a built-in relationship between .doc files and Microsoft Word, even for hyperlinked files - which are not being imported or exported. Nobody could be blamed for not trying that first! Maybe there is a better technical explanation that does make sense, but I am glad it works nonetheless.

This conversation is no longer open for comments or replies.