Problem with tag colours and groups when rolling up or copying to a new map

  • 2
  • Problem
  • Updated 3 weeks ago

When I create a map with tag groups and colours and then try to set up a map roll-up to a new map, the tag groups and colours both disappear in the roll-up map. The tags are all lumped, uncoloured, into the General Tags group and can't be edited (this is some of the same behaviour that Nordman has also reported on recently).

This happens even if you copy the tag groups across from the source map to the prospective roll-up map's Map Index prior to creating the actual roll-ups. This undermines the usefulness of roll-up maps.

There is a similar issue when just copying a branch to a new map. If you first copy the tag groups into the new map's Marker Index the tag groups and colours will be recognised, but only at the main topic level. Any tags belonging to tag groups on subtopics are again put uncoloured into the General Tags group.

And if you don't copy the tag groups across first all the tags, including those at main topic level, end up uncoloured and ungrouped in the General Tags group.

Photo of Alex Gooding

Alex Gooding, Champion

  • 1062 Posts
  • 255 Reply Likes

Posted 1 year ago

  • 2
Photo of Medved Hnedy

Medved Hnedy

  • 8 Posts
  • 1 Reply Like
Based on Alex's description I tried and succeeded with the folowing method (at least it did on my MM 2019)
It is tedious but better than trying to fix all the broken tags.

0. Copy the tag or tag groups your map Needs. You Need to copy inbuild tags too (e.g. Kanban got broken), but at least some inbuild Icons (Progress) seem to Transfer fine.
1. I saved a copy of my map and worked on the copy
2. I use Right layout so I need to order my Levels to be in even columns:
2.1 Under Ribbon Format/Layout I selected "Match width for all topics"
3. Using click-hold-dragDownAndRight I selected and *deleted* the higher Levels one at a time. Hiding doesn't cut it (pun intended :P)
3.1 Actually, if like me you have tags only in the first three Levels then you can delete Level 3 and all above first, then Level 2 and then Level 1
4. Copy central topic (or your root topic) to the target map.
5. In the source map undo to un-delete the next Level and copy it. Obviously you need to do this separately for each first Level topic's subtopics. This is the tedious part.
5.1 I select parent, <right-arrow> to top child, <shift+end> to select all children, copy, <ctrl+tab> to target map, navigate to target parent and paste. Then <ctrl+tab> to source map and repeat.
6. As you paste check that no broken tags appear in the General group. This only happened to me if I missed something, e.g. I forgot to expand a topic and delete ist tagged children.
7. Repeat 5 and 6 until your're done.

It's horible, but if you have lots of tags, it beats the alternative. Those broken tags can only be removed by mouse and context menu on each topic. Also the map index cannot properly separate them from proper tags with the same name.

Maybe after a year this can get fixed or somebody can make a macro.
(Edited)
Photo of Medved Hnedy

Medved Hnedy

  • 8 Posts
  • 1 Reply Like
I believe I found a solution to the problem so I am sharing. I am not sure if all the following is necessary but it worked sofar:

I. Instead of just copy-pasting tag groups, use Generate and apply a Marker list
1. Under Design Ribbon/Themes/Theme Organiser >> Marker Lists, generate a new marker list from current map.
2. Using the theme organiser apply this map to all the files you want to use it
3. Copy-paste the topics
Using this method, I could transfer tags including groups and fromating in one go when copying a 5 level deep structure of tags.

II. Modifying your markers
1. You need to find the .mmms file containing your markers. On my PC it was under ...Mindjet\MindManager\19\Library\ENU\Map Marker Lists
2. Open and edit as needed
3. In all files where you use the tags, use the Theme Organiser to re-apply the marker list - marker formating should update
4. Copy-paste between maps as needed

Worked:
- add tag
- add tag group
- update tag color
- changing group name

Did NOT work:
- changing tag name
- moving tag to another group
These cause the tags to become broken general tags. Interestingly, reverting the change and reapplying the list, REPAIRED the proken tag