relative links in web export

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
Beim WEB export wird die option "Datei nicht kopieren- relativen Link erstellen" gewählt. Der expotierte Link ist dann aber nicht relativ, sonder absolut. Was ist das Problem?
Photo of Walter

Walter

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Nick Duffill

Nick Duffill, Champion

  • 505 Posts
  • 168 Reply Likes
Hello Walter - I am sorry, I can only answer in English.

Are the linked files on the same disk drive as the map and the exported site? If they are on different disk drives, then relative links cannot be created.
Photo of Walter

Walter

  • 3 Posts
  • 0 Reply Likes
Hallo Nick, thanks for your reply. I`m sorry but I put this ticket in the German web site.

Yes, it is all on the same drive D. The original map, the documents and also the Web export. In the original Map the documents have a relative link. But in the exported WEB they don`t have. They look like this: file:///D:/Dokumente/Doppler%20Radar.pdf in the map the same link: ..\Doppler Radar.pdf . In the option settings I set it to “not copy and relative link”.
So for my project this will not work.
Photo of Andrew Wilcox

Andrew Wilcox, Champion

  • 1032 Posts
  • 177 Reply Likes
I use the setting "Copy file - Create relative link". The web export creates a LinkedDocuments sub folder in the web export folder containing all the relatively linked documents? (Probably not with your current setting).

If you want to use your current setting and allow other users to see the linked files and keep them in the original location they will need to be in a folder that is "visible" to them all. A folder on your PC is not likely to work. A network or web drive should.

Are you looking at the link displayed by the mouseover?

What is the link in the html file (Open with a text editor and look)?

This conversation is no longer open for comments or replies.