Smart fill and Topic fill NOT working on topic

  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
  • (Edited)
I have a 3rd level sub topic that will not change fill color whatsoever. It has x3 Calculated Topic Properties. There is currently NO fill - despite the object format suggesting there should be. Also I have a Smart fill looking to change the color of the fill when the % Complete Topic property is 100% - which it is. That has no effect too!!

There was originally - task info on this topic but I have ameneded the display options NOT to color code the fill when the task overdue. I have also removed the dates attached to the task -the only thing I have left is the resource doing the task (A persons name)..

Confused....
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes

Posted 4 years ago

  • 1
Photo of aHa!Coaching

aHa!Coaching, Champion

  • 1192 Posts
  • 116 Reply Likes
Could you post a screenshot of the topic so I can try to recreate the map on my system?
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes
It's sorted when I upgraded to 14.3.192
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes
On further checking - this is still broken. Specifically, it appears the smart fill will NOT change the topic color when the topic property is a % (from a calculated formula). I'll send a screenshot.
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes
In the above example the following is happening:

1. The default green Children topics (Environmental Health, Parking Services, Processing and Enforcement) Have the 2 Topic Properties of Device Count and Device Completed.
2. The Parent (Exchange Building North) has the 3 formulas doing the calculations called: "Total No. Devices", "Total No. Devices COMPLETED" and "% Completed"
3. I have a Smart fill set on the Parent to colour the Parent Red if the % Completed Value is below 25% - in the example shown I have made the Devices completed upto 54 and the % Completed is 53.46%.

When I first set the Smart Fill is was red as the % Completed was 0%. I then upped the value to 53% to see if it would drop the red fill from the smart fill - it did not!!!

Ideally I should like a traffic light system of :

0-25% = Red
26% - 74% = Amber
75% and Above = Green

But this does not seem possible - unless I'm missing something obvious.

Interestingly - if I try the smart fill on the parent with an INTEGER value it works!!!

Confused!!
Photo of zak_neutron

zak_neutron

  • 15 Posts
  • 4 Reply Likes
Anybody from Mindjet - can you shed any light on this????
Photo of Marian Kocmanek

Marian Kocmanek, Official Rep

  • 367 Posts
  • 64 Reply Likes
Hi Zak, 

It will be best if our Support Team can take a look at your Map. Please log a ticket here and attach a copy of the Map. 
Photo of mooks

mooks

  • 1 Post
  • 0 Reply Likes
Hi, I think you might need to change your smart fill values to 0.25 (not 25) etc to handle the percentage values.