Smartrules with AND Condition doesn't work

  • 1
  • Problem
  • Updated 4 months ago
  • In Progress
I tried to use 2 conditions in a Smartrule (MM2020), but it doesn't work. Is it a bug ?
see example below (sorry it's in french)

Photo of FCR

FCR

  • 12 Posts
  • 2 Reply Likes
  • Frustrated

Posted 4 months ago

  • 1
Photo of Nick Duffill

Nick Duffill, Champion

  • 601 Posts
  • 245 Reply Likes
I tried this and it seemed to be working OK on 20.1.131.

I think the "Next two weeks" is whole weeks starting on a Monday, and not the next 14 days from today. Could that be the problem?
Photo of FCR

FCR

  • 12 Posts
  • 2 Reply Likes
Thank you Nick.
Can you explain your test ?  because I've tried with several cases and this "AND" condition never worked whatever the conditions :-(
Photo of Nick Duffill

Nick Duffill, Champion

  • 601 Posts
  • 245 Reply Likes
I have uploaded the map here. You should be able to download it to examine the SmartRule. (Edit: it seems as if the online map does not display the mark-up added by SmartRules! But it is present in the client).
As far as I can see, the priority icon is only applied when the task starts before the next two weeks, and if it has the "Prod" tag.
I saw you allowed a manual override of the effect, i.e. manually overriding the priority. I have not tested this aspect.
For anyone visiting this later, note that the SmartRule is date-sensitive so this map might behave differently later.
(Edited)
Photo of FCR

FCR

  • 12 Posts
  • 2 Reply Likes
Wahoo !!!!    It's bizarre !!!  It works fine with your map, but same SmartRules applied to my original ones does nothing .....

In fact, maybe some ideas from next 2 questions:
Does anybody knows if there are some limits of number of rules ?  and can we use the result of a smartrules as an input of another one ?
Photo of Nick Duffill

Nick Duffill, Champion

  • 601 Posts
  • 245 Reply Likes
Hmm. Are there any other SmartRules that control the Priority icon? I think if it has already been written by a SmartRule then later rules that write to the same effect will not be processed. It would be worth turning off some other rules to see if this one works on its own.
Photo of Nick Duffill

Nick Duffill, Champion

  • 601 Posts
  • 245 Reply Likes
If you can supply a map that fails then it can be sent to MindManager support for investigation.
Photo of FCR

FCR

  • 12 Posts
  • 2 Reply Likes
Done, thanks
Photo of Andreas Lercher

Andreas Lercher

  • 119 Posts
  • 52 Reply Likes
Please can you change the language to German or English in the Options. Than open the Smart Rule and take a Screenshot
Thank you
Photo of FCR

FCR

  • 12 Posts
  • 2 Reply Likes
Hi Andreas,
It seems it doesn't come from Smart Rules directly but maybe some limitations or something else because in a very simple map the same rule is working fine ...
Photo of Andreas Lercher

Andreas Lercher

  • 119 Posts
  • 52 Reply Likes
Strange
Do you have more than one smart rule in that map?
Bear in mind that the rules affect each other
Photo of FCR

FCR

  • 12 Posts
  • 2 Reply Likes
Yes several but not "linked"
Photo of Andreas Lercher

Andreas Lercher

  • 119 Posts
  • 52 Reply Likes
They don't need to be linked. Smart rules are done in the order you see in the define window