Total application freeze after throwing "A required resource was unavailable" message

  • 1
  • Problem
  • Updated 9 months ago
I've been getting the above message since last week.  Mindjet then goes into a total freeze, losing any unsaved changes and requiring a Task Manager End Task to kill it off in order to start again.  Is this perhaps a known issue?  (I'm on the latest fast loop Win 10 release, using OneDrive (personal and business) in 'clear space' mode.  MindManager version 18.1.154)
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
  • a wee bit frustrated for having to continuously save or lose work.

Posted 9 months ago

  • 1
Photo of David Walsh

David Walsh, Official Rep

  • 133 Posts
  • 31 Reply Likes
Wilhelm,

Thank you for your comment. Did the software work fine for a while and then this issue started to occur? I would suggest closing the program and then going to the Control Panel >Programs and Features and select Mindjet 2018 and run the repair on the software. See if this improves the behavior. If not, you may want to try a uninstall and reinstall of the software. If the problem continues could you send a report to our customer support group at customer.support@mindjet.com with as much detail as possible and we can work with you on your issue it would be good to get any related event log if one is created from the event. 

Best Regards
David 
Mindjet Customer Support
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
Grrrr...  just lost a lot of effort!

Steps taken since yesterday:
  1. Repair - no change, still freezing.
  2. Re-install - it looked good at first so I started saving less frequently (i.e. every 3 minutes as opposed to every 3 seconds)... and then it just failed again now after quite a bit of work.  (I can't be sure, but I think it might have happened when I tried to select multiple cells by dragging over them with the mouse - the screen freeze shows a little rectangular 'selection' box appearing just before the freeze.)
It doesn't appear to be my local installation - it seems there's a variable in either the latest Win 10 version, or perhaps the way OneDrive handles the files that's not being computed by Mindjet MindManager, or maybe something with drag-select?

Next steps:
  1. I'll try and find an event log - does MindJet record its own or do I need to use the Win10 log?
  2. Pending answer for step 1, I'll submit it to Customer Support.
Thanks.
Wil
(Edited)
Photo of aHa!Coaching

aHa!Coaching, Champion

  • 1192 Posts
  • 117 Reply Likes
I'm not aware of any Mindjet logs, so I think you'll need to dig into the Win10 log.

Also, did you try to use local storage (instead of OneDrive) and see it that helps?
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
It's a bit of a pain for me - we're using OneDrive extensively to collaborate, i.e. no local files policy, but I've done a test with local only files and it just failed again.

I'm beginning to think it has something to do with the drag select.  I've noticed the fail on the last three (at least) occasions occurring when I was in the process of selecting multiple entities by dragging over them with the mouse.
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
...also submitted the Win10 event logs by email.
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
Thanks, David.  I've done the repair.  Will let you know how I'm going.  (Thanks for the very quick response!)

...and yes, it worked perfectly before.
(Edited)
Photo of Werner Beck

Werner Beck

  • 30 Posts
  • 4 Reply Likes
Just for the record, I've had that happen to me once so far, yesterday.
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
Thanks for that, @Werner.  It helps to know that it's not isolated to my environment.  Would be keen to know if you've noticed whether it had to do with selecting multiple objects by dragging the mouse over them perhaps?
Photo of Werner Beck

Werner Beck

  • 30 Posts
  • 4 Reply Likes
Wilhelm, I can't really recall what had caused that crash; will take a closer look if it happens again.
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
Becoming more and more convinced this has to do with multiple object selections using the mouse... 
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
Just had another one as I was dragging over objects.  Managed to get a screenshot - fail when I was about 1/2 a second into the selection drag.   I realised this because I started saving instinctively every time before selecting multiple objects.

(Edited)
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
Update:  it just happened now when I inserted a link.  (First time it didn't happen when selecting multiple objects, however, one could argue that linking objects could use the same procedure as select on some level...?)
Photo of Wilhelm

Wilhelm

  • 28 Posts
  • 2 Reply Likes
Update:  I can't say that it's only when I'm selecting multiple objects.  It just happened when I assigned a task progress.