Visual C++ prerequisite for Large Scale deployment

  • 1
  • Question
  • Updated 9 months ago
I am preparing an installation package for MM2019.  The Deployment Guide states that one of the prerequisite software is Visual C++ run-time 2015:

 - vcredist_2015_x86.exe or vcredist_2015_x64.exe installs the VC++ Redistributable components for Visual Studio 2015.

Obviously a 32-bit OS can only install the x86 version.  However for 64-bit, both could be installed.

There is only one MSI installer (Mindjet MindManager 2019.msi), which is 32-bit (it defaults to C:\Program Files (x86) for installation path).

Which leads to my question:  is the x64 version of the vcredist truly necessary on 64-bit systems, or will just the 32-bit suffice?  Or do I need both?

Thanks.

Photo of BdB IT Support

BdB IT Support

  • 2 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 1
Photo of Ary Velstra, Expert Trainer

Ary Velstra, Expert Trainer

  • 1614 Posts
  • 242 Reply Likes

I never had this at installation, since my installs are always next, next, next  etc. When you follow that it always goes OK. But.....you have it so:

Ask Mindjet Support via the website www.mindjet.com.
Photo of BdB IT Support

BdB IT Support

  • 2 Posts
  • 0 Reply Likes
Well, with the standard installer that may be the case. But with the Admin installer, the vcredist and .NET packages are separate from the installer and must be pre-installed (either manually or via a deployment system).  The Admin installer does not install them.

It just seems to me that a 32-bit package should only need the 32-bit vcredist.  I was hoping that someone out there had some experience with the Large Scale Deployment / Admin installer and could confirm that for me (and save me the extra time of having to test it).
Photo of Ary Velstra, Expert Trainer

Ary Velstra, Expert Trainer

  • 1614 Posts
  • 242 Reply Likes
That someone is there for you. He/She is called MIndjet support.